Location problem

Having positioned the cursor on the map whilst building a post (Bronze hopper | Observation | UK and Ireland | iSpot Nature):
the grid reference sets itself to my home address, which is where the location appears when the post is saved.
It’s meant to be (approximately) TF 004 038, but reverts to TL 167 840 when saved. Oddly, though, the latitude and longitude are given correctly.
The same thing happened with Last Harebells | Observation | UK and Ireland | iSpot Nature and had to be corrected.
Typing in the grid reference seems to ‘activate’ it, and it then responds to the cursor if changed.

Do you allow the system to pick up your location as if you were using phone in the field and it was trying to get the place where you were making the observation.

My images nearly always already have the location in them which the system picks up but if there is no location that the system can read then it asks if I want to allow it to detect my current location which I don’t want as I normally enter the observations later from a desktop in a completely different place to where the observation was made.

I have just tried an observatoin without embedded location and initially even after click on map nothing happened then when i tried to go to different menu it stuck in the coordinates and OS grid ref so perhaps there is a problem with this at the moment.

My camera doesn’t have GPS so I do it manually. I have a lookup file of grid references to copy-and-paste, but it’s often just as quick to drag the map.

I’ve had the same problem again today. The trick seems to be to enter something - anything - in the grid reference box: just clicking in the field will do. Then it will accept a point clicked on the map. But if I don’t do this, it appears to respond, then sets the location to my home.

Does the browser ask you if you will allow it to put in your current position? I think it should ask before doing so and if not then there might be a setting to force it to do this.
When it asks I just say no so I can put in the position of the observation.

No - it allows me to click a map location, but ignores it unless the grid reference box (haven’t tried the lat/long ones) is ‘activated’ by clicking in it.

Have you tried logging out of google or any other software that might grass up your location?

Just linking your location issue with one sort of connected with my post this week as I’d been looking for this, Amadan. Mine is here:

I don’t use Google for browsing, though I do use YouTube. But I hadn’t logged into that yesterday.

The checking needs to be a bit more thorough than that.
Any bit of software that links to something that shows location is capable of doing it.

Good morning
V late to be looking at this and forgive any statement of the obvious here: Have a look at all obs of Queenies or indeed of Badgers, I believe iSpot automatically obscures their location for conservation/legal reasons, regardless of what the observer does. The level of protection accorded in law makes the specific location eg of badgers something to be concealed. Sorry if your comment above already discussed elsewhere!
Came to this thread because having some location issues of my own - specific locations that are not accurate are sticky - no matter what I do, they keep returning to the obs. On the case though, having read some of this thread. :slightly_smiling_face:

Thanks for this, Mags! It’s very interesting and it happens like you say to Queenies and Badgers! I’ve responded to the other post under Mike’s comment and quote you there.

The problem persists.
Less of an issue, but a puzzle nonetheless; is what happens when I open any forum thread. The initially-visible comment is highlighted in fluorescent yellow for several seconds, before reverting to the normal appearance:

I suppose it grabs my attention!

It looks like some kind of “unread” flag that shows until the page is fully loaded and then un-sets once the page load is complete.

I had assumed that this was intentional - highlighting new responses.

That could well be - if so, I assume a recently-introduced and unannounced change. It’s not a problem, just a curiosity,

Discourse is quite frequently updated and I assume this was a change in the default settings.

Nope, theory does not withstand the testing! I realise I must have obscured eg my beaver iSpots and not remembered :frowning: