The OpenScience Laboratory The Open University

iSpot Forum

403 error - is it just me?

On a phone I usually choose the option ‘open in new tab’ when looking at individual observations from the home page. Today it won’t let me do it; I get a ‘403 forbidden’ error and it tells me I don’t have the correct permissions. All the tabs I left open from yesterday are giving the same error, but if I just tap on a thumbnail observation on the homepage it opens as normal in the same tab. What’s going on?

Me too.
With me it occurs when I try to access observations via changes tracker or activity tracker.

It seems a wider problem and also been raised this morning in another topic.
Clicking on a ‘Title’ from my ‘Changes Tracker’ is bringing up the message:

403 - Forbidden You do not have permission to view this page.

I get the same non-result via changes, activity tracker, following another iSpotter…

This problem is across iSpot.
Results from a search do not link
Chris is on the case but off-duty.
He wrote “…will look into this on Monday.”
I know he has logged in to try but his last message was " Bloody computers!"
We all need to think of other things to do…

OK, off to the south west :grinning:
Thanks for the note, dejay and thanks in advance for sorting it, Chris!

I suspect that it is because there is no “remember me” button on the log in panel.

I’m getting the same, eg from the changes tracker
And now even from the observations list (from both I can only access my own observations)

JoP managed to work through a lot of observations last night at her usual rate of knots, but it’s still 403ing when accessed from the changes tracker.

So I looked a little further.

Observations open up cleanly when opened in the same tab, but not when opened in a new tab, or a new window. (The changes and activity trackers automatically select a new tab.)

I hadn’t paid attention earlier, but looking now the header, footer and sidebars (including location map) are displaying correctly. The observation starts to display, and is then replaced by the 403 message. Looking at the page source I thought for a minute that the description had been served, but on looking more closely this (and the counts of identifications and agreements, etc) were in <META> tags.

If what’s gone astray isn’t obvious, changing the trackers back to opening observations in the same tab would likely serve as a temporary fix.

She did and I had three pages of yellow this morning that I could not attend to.
Anyway, am I right - is the site running NOW 11:10?
I suspect that @Chris_Valentine had an early start today if so, then THANKS :rooster:

Still 403s when opening observations in new tabs here.

Seems OK in Orkney
Clear all your Ram, shut down and reopen.
My tracker links are working.
But I am off for a couple of hours…

No change after a restart.

Yes, after a promising hour or so, things have regressed. In my Tracker, my OWN observation links open, few others do. There must be a clue in there.

Just tried again to see whether it was working. I had YouTube playing, which slows things down. It looks as if the browser managed to display a lot of the observation before the 403 kicked in.

I have had pretty well the same thing after a period of inactivity when pulling down the profile tab. It runs some way into the screen before throwing a 404 error requiring a screen refresh to get the log in screen. From the changes tracker the partial screen and 403 error is as above.
The password does auto fill after the 404 error.
Ubintu with Firefox browser.

My guess is that, come Monday morning, Chris and the team will be grateful for ANY useful information here.
Certainly my experience is that links to my Own Observations all (usually) work. My tracker has the greatest hang-up. Few links work from there and generate the usual global 403 error.
The failures seem to be gradual then abrupt.
I can use the Explore Community (filter) well to find some of the Observations in my tracker. From there I might be able to find the right Observation, right click and open in a NEW tab - it sometimes works. But it is a hopeless procedure. I am on a PC with W10 and Chrome.

I suspect Chris MIGHT have to roll back to a back-up version which MIGHT mean losing observations made in recent hours or even over the weekend - do nothing precious or keep a precise record.

Just now 1042 (Sunday) All links in my Tracker are working. I can go back 10 pages and they still work,
Some magic has happened. Will it last? Didn’t!

1049 and failing.

Following the annotations on your screen captures.

Open observation in a new tab/window while remaining logged in - fails
Open observation in the same tab - works (and you can still respond as you are logged in)
Open observation in a new private window (becoming logged out) - works (but you can’t respond without logging in again)

So, we can see comments, etc., from the changes log, by opening in new private windows, which as long as we don’t want to respond, is sufficient. I haven’t tried logging in on such a window, but if it results in reloading the observation in the same tab the pattern above infers that it would work.

addendum: user pages seem to be behaving in the same way as observations, except that if you open a user page in a new private window you see the profile but not the activity tracker (presumably because you’re not logged in.) The same goes for project pages.

Yes, most things work when not logged in. You can open Observations but have to log in for every and each occasion to comment or agree,
It is very difficult to respond to the Changes Tracker - but possible!
I have sent my summary to Chris and Mike. I imagine it might be a difficult fix
Thanks…