Editing a project


500 - Internal Error
Something has gone very wrong - please try clearing your browsers cache & cookies, restarting your browser and returning to the page that caused the problem. If the problem persists contact iSpot.



It worked once but removed all my coloured text. When I’ve tried to reinstate the text as it should be, I get the error.

I will report it to programmers, there is some work going on in that area so they may have altered a bit of code that should not have been altered.

Thanks, Mike.
extra needed here to post

I went there - seems OK chus now

I’ve just had another go on both Firefox (my usual browser) and Chrome and got exactly the same 500 error on both. It has stayed red as that’s the HTML code you used.
You have different permissions and access rights these days. It would be useful to know if another “ordinary” iSpotter could edit their own to see if it’s a problem across the board.

I spoke to the programmers about this and they said they had not altered anything but odd if only one person gets the error.

Yes, it’s odd and I have just now tried on my husband’s computer and got the 500 Error. As the programmers seem to need more information, I can just make out ‘Update failed’ on a different layer in a pink rectangle “under” the Error message.
Perhaps you can let the appropriate people know. I always keep a copy of my Project/Observation text in Notepad and this is particularly important when using HTML for italics or colour to save having to rework it. If this issue isn’t resolved, then I won’t be able to edit any project when it’s due to be parked in Dejay’s list in future and so I’m likely not to put any work into future projects.

I’ve solved this issue courtesy of my husband who suggested editing by inserting one paragraph at a time. The first paragraph failed and so we changed the HTML and now it saves. Something must’ve been changed since I first created the project in August 2022. I haven’t changed the first paragraph.
Here is the code before and after.

<p>Carousel credits: <strong>Mags49</strong>; <strong>Aldcameron</strong>; <strong>HB</strong>; <strong>Mags49</strong>; <strong>dejayM</strong>; <strong>Nick Upton</strong>; <strong>Gulvain</strong>; <strong>Nick Upton</strong>; <strong>dejayM</strong>.</p> 


<p>Carousel credits: <strong>Mags49; Aldcameron; HB; Mags49; dejayM; Nick Upton; Gulvain; Nick Upton; dejayM</strong>.</p>

I have an Project and some Observations that break the current Code rules. and so cannot be edited at all
The HTML code is very limited compared to the pre 2017 recode
Here is my Marine Fish one, I had to replace it and have never finished it
The other three projects I just deleted - they were loaded with Hyperlinks in HTML code
What we have now is satisfactory but not very easy to manage. A new coder is in post and some new proposals are forthcoming - I do HOPE that nothing existing will be ruined.
I should say that ANY slightly careless edit can destroy our own efforts. I have ALL my projects stored alphabetically as plain (.rtf) text in two backup drives.

Just had a quick read of your Marine Fish project. What can I say? What a shame - it’s very disappointing to find issues when an edit is warranted.
I didn’t comment on yours as my fiasco was caused by something changing since 2022 and who knows what could happen anywhere!

Unfortunately computer code constantly has to be ‘updated’ and ispot is unfortunately based on several interlinked programs all of which have to be updated for security reasons. If they are not updated then the site will be shut down as the security people think that hackers might get in.
I suspect it is one of the updates that has caused this issue.

Thx for your responses, Mike. I won’t be using so much punctuation among a carousel link dotted with html again.