Filter by taxonomy: problem or just me?

I hope I’m not posting this in the wrong place or being completely numb in the head but I’ve been having some really frustrating problems and I can’t figure it out. When I first started using iSpot, I used to be able to filter by taxonomy on my own observations by putting in things like ‘Diptera’ and it would give me all of my posts that were flies. I don’t know if it’s just me or if it was actually changed but now if I filter by taxonomy with absolutely anything, it always says “No results found”. I looked through the Help section and looked through some other posts here in the forum and I haven’t found (as of yet) anyone else mentioning the ‘problem’. I just wondered if anyone else has the same thing or if it’s just me? A workaround would be for me to just tag every fly with “diptera” which I’m not really fond of doing BUT I will do if needs be. One thing I have noticed is that on a lot of posts like this on the forum, there used to be a lot of argument and frustration - I’m not here to vent, I just want to know if the filter by taxonomy works for anyone else or if I’m just useless at it!

I have just tried Diptera and my name and it seemed to work here is the ridiculously long url of that attempt:

I wonder if you are trying to filter from the wrong place as there are more than one place where it is possible. I always go to the ‘explore community’ tab and select ‘map’ then click on filter community observations.

1 Like

Yes, I’ve occasionally had that result (no result!), I think for the reason Mike gives. I just did:
explore community - map - filter community observations - then entered Amphibians and Reptiles at the top and my name at the bottom and I got the result I expected.

So I think it’s worth a try, it’s a case of getting the starting point right I think. Good luck! And I think this is exactly the right place for your very reasonable enquiry btw. :slight_smile:

I’ve had no problems - I use this function a lot.
I’ll check my ‘flies’.
Don’t feel bad - help is always at hand via the forum, and we’ve all had problems from time to time.

I have mentioned that a few times to admin, It prevents us from doing so many useful Internal Links.
That is why some of us have resorted to BitleyLinx
Filtering by Taxonomy is easy from the Browser @Jins_Weenus .
Find an observation, look at the Taxonomy Tree, click at the level that interests you

Thank you for your help all but I am still encountering the same problem all this time later lol! I’m not sure how this works but I will try to add screenshots to better explain what my issue is.

I have tried both by going on “My observations” (first screenshot from that) and from the “explore community” (third screenshot from that) but I get the same problem each time. I have also tried going “Explore community” onto “map” instead of list but it still comes up with 0 observations. I’ve also tried adding extra filters like group but it still doesn’t want to work with me, even now! I’m still certain that I’m being a numpty and doing something obviously wrong but my head just isn’t putting two and two together. I did wonder if I was typing the genus and what have you incorrectly but I’m picking the option from the drop-down menu. Every other part of the filtering works for me, just not the taxonomy bit which is the part I could really do with figuring out lol!

Oh my life, well now I’m extra confused! I managed to get it to work!

I think my issue may have been that it put me on Global for some reason? I ended up going through the species browser for Animalia, going onto the map for Animalia obs and then filtering by Noctuidae and myself. Doing that seems to have fixed it again.

I think my problem could be that I have one sole observation on Global (from Tasmania) and all of my others are UK so perhaps it confuses the system? Either way, I think I have fixed it!!!

a few things
the site is far too lumpy to do any successful filtering. I think IT OU are on the case not just the Curation team
If you browse Global, either but changing community or opening a Global Observation, iSpot sometimes assumes you’d like to remain there - I reported that issue long ago but it is more often an issue with iSpot Southern Africa Obs.
If you open a Global or ZA observation then change your community to UK afterwards
The problem you illustrate is very likely to be a problem with the Server - it is HATING filtering of any sort except the Activity Tracker! It is simply hanging up. I have been trying to Filter all morning!