More map problems

I’ve entered three observations in Kent this morning with the GR TQ373428 but when I checked back the map shows the observations occurring in Surrey.

Between Newchapel and Lingfield? That is where the TQ373428 grid ref is? which is indeed Surrey?

No, sorry, I didn’t explain properly. TQ373428 is what iSpot records, no matter where I am - I was in Kent this morning at TQ 494 493.
But I’ve found that I can fix it by ‘hiding location’ and then unhiding it.

Yes this workaround seems to fix a number of issues with location, I am currently using it myself with todays observations. Will mention it to Chris if he does not pick up on this thread.

Interesting! I have now seen this but am on leave until next week. Will take a look when I’m back.

Can’t seem to do much today:-(

Location won’t stick, defaults to my home so constantly checking and hiding location! But that is taking so long. Also, can’t upload some photos, no idea why. Added a few observations, intended to be quick fire things just to get them in place, but that’s not what happened.

Can’t even see my own project now, just the spinning blue waiting thing.

Okay, I suppose it’s down to me and not knowing what a …cache even is - just predicting someone will ask me to empty it!

Will come back later and see if I can do more.

Yours grumpily.

PS won’t log me out so going anyway

There are days like that. I found that coming back an hour later did the trick.
I’ve found emptying my cache has unwanted side-effects, such as my pc forgetting all my passwords. Best thing is to chill for a while.

Kind thoughts, thanks!
Still had problems with photo upload but above all with location. Will maybe try again later, since it eventually allowed me to see my own project that I wanted to edit.

Did you try that trick of going to the map and clicking on the location, then if no lat long coordinates fill in, click on ‘hide precise location’ box. for me this then fills in the coordinates, then I click in the hide precise location box again to untick it and the location remains where it should be.
Chris will look at this bug when he gets back.

I think that just worked for me this morning, thanks. Takes a lot of energy to just do a simple thing, hope this jiggery-pokery won’t be needed long term!

For some reason, this failed to post on the first attempt…
I had the same problem - a recent discussion. I found that clicking in the grid reference box first seemed to get it’s attention: then the map responded to changing locations. Without that, the map seemed to respond but then quietly reverted to my home location.

What method do you use to empty your cache? If you use something like “delete all private data” in the browser, it will clear your cookies as well as the cache - which you probably don’t want to do. I use CCleaner to empty just the cache - you can use just the free version to do this:

Its sounding like the browser, having been permitted to use your computer’s location (or at least what it thinks it is - its often the location of your ISP), is now using that in preference to what the iSpot code might be getting from the image. You can disable this in Chrome via this part of the settings:

If you see iSpot listed on the very bottom-right section, you could delete that entry. Or if you want to stop all sites from getting your location, you can prevent that too:

Thanks for the info, Chris. I’ll bear that in mind. But so far I’ve found that the ‘something has gone very wrong’ messages don’t repeat if I keep refreshing the page.

I get the feeling the server is still in a strop about having its power die on it!

Well I would be in a strop if that happened to me!