Photo uploads not working?

Managed to upload one photo (~0.9MB) last night; further attempts to upload the same photo today have failed. One photo at 0.2MB succeeded.
No apparent problem with my internet connection: a Teams meeting today has - sadly - gone on uninterrupted!

When I have time later today - I’m working on database backups at the moment - I’ll have a look in the storage where images are uploaded to and see if I can see any of your files. Are they named in any particular manner I might recognise? The file system arranges uploads into one folder per day. It will be interesting to see if any of the file is saved but is truncated or if it doesn’t even get that far.

Sadly the system doesn’t keep any part of the original filename, so tracking yours down would not be at all easy!

Chris. many thanks for your continuing efforts. I don’t know if it will help but the photo at failed to upload on several occasions before it got through; it has also failed several times since (and has stuck again while I’ve been writing this post.)

Yes it’s being very unreliable this evening. Managed to get one of three images uploaded to one entry ( but despite multiple attempts it would not add the other images of this organism.

A second attempt to enter something and it refused to upload even one image so I’ve just left it as a placeholder until such time (

Hi David, Thanks for updating us…and sorry you’ve also had problems uploading. The images you did manage to upload are fantastic btw. So sorry you couldn’t add the additional’s,. :frowning: Hopefully this can get sorted out. I was able to load yesterday but used my mobile device, not my camera and laptop…will be testing this out today. And we have Chris on the case too :slight_smile:

I am finding that if I ask the upload fairy to do too much, say img greater than 7Mb or a few too many or a big one followed by a small one, then it stalls.
I have often had to wait too long for a 2.4mb one but by adding the SAME Img again it loads. I then cancel the unloaded one.
For me this has been the case for a few months

Following your suggestion, I tried adding the same image again but ended up with the same (non-) result.
Also tried turning off the Wi-Fi connection and reverting to wire, again with no improvement.

Something else to try is to use phone to do the upload i.e. avoid your internet provider completely and try an upload just using the data on phone. This is not a long-term solution of course but just a one off try to rule things out.
I could also try an upload for you if you send me a set of images for an observation, I will have to reset your password to do this then you will have to reset the password again once I have tried it - the only reason for trying this is to see if there is something odd about your account itself. Can’t see any reason why there should be anything odd about it but just a process of removing any possible causes.

Not sure I can manage it with the phone - it’s old and uses the Windows OS (and one of the best decisions MicroSoft ever made was to discontinue that OS!)
I’m happy to send you some of the images I’ve been failing with. Would you like to contact me by email with details of how you would like this done?
Many thanks.

Psst! Don’t tell anyone but the gremlin’s having a snooze and I managed to creep past it!

1 Like

The whole site is tetchy today. Note that is seems to reverted to an Old Home page, so I suspect there are Server Issues
I have just uploaded a whole 8 photo ob. (by luck and repetitive logging in!)

We had an issue this morning with lots of search engine bots all hitting the site at the same time. I’ve had to exclude most of them as they were generating just too much traffic for the site to cope with.
The site is now running with the new design but its still being a bit flaky.

Thanks Chris (and Rachel below)
I have noticed a few layout changes - home page specially.
It’s hard to know whether these are deliberate or just the server booting up old versions.
I guess we’d like to be constructive about changes, so can you summarize the deliberate ones please.
Do we benefit from the SearchBots. It’s VERY common to see 4 times (x6 for a period yesterday) as many guests as users logged in.
I have noticed that Google Searches nowadays produce more iSpot results - try searching for :heart:iFocus in the Different Search Engines.
The site is still ‘tetchy’ this eve 28th. With photos not displaying, occasional lock outs and bad load-ups. It seems ill-tempered.

Thanks for the feedback @dejayM. Yes, we have noted a few similar glitches and these are being looked into. Please do bear with us iSpotters.

Today has been a challenge! Before going out this morning I tried to get into the site and just kept failing. Later on, I thought I’d see what was new and add a couple of observations (have big backlog!), it was very difficult. Lots of error messages, blank pages, observations with no photo and no info shown…and it all took ages.

I’ve just uploaded 7 images of around 1.4Mb each at good speed and with no problems. Hopefully today’s server upgrade has solved the problems.

Many thanks for your help.

1 Like

I had a 7 photo upload hang yesterday, but I’m blaming that on Windows 10, which doesn’t run smoothly with 4Gb of memory.

I also had attempts to open the Plants carousels hang, and had to refresh the main page.

Its probably down to the ongoing issues with the new server architecture. Having run (almost) happily since yesterday morning, it just went down again. Restarting one particular server in the cluster brings it back to life.
I have noticed that filtering on the top carousel on the home page is being incredibly slow - even slower now than when on the old architecture.

Anyone still having problems with image uploads? If so, could you tell me how big your JPG files are and how many you’re trying to upload at one time?

1 Like