The OpenScience Laboratory The Open University

iSpot Forum

Photo uploads not working?

Anyone else having problems uploading photos? I see the rotating egg-timer and the progress bar which doesn’t progress. No activity on the internet connection. I’ve re-booted my computer and am getting the same again. (And if you see this it shows I’ve got a live internet connection!)

I never actually upload my photos. I drag them across from the folder to where it say ‘drop images here’. Have you tried that?

Yes … I drag the photos … and the system then uploads them from my computer to the iSpot computer.

Narrowing things down a bit, I’ve got the same problem on two different computers. I turned off the computer and router and left them overnight but the problem has persisted. I’ve just successfully uploaded the same photos to FaceBook.
I also note that I’m having to log on to iSpot where previously I’d stayed logged in. Could both of these be the law of unintended consequences operating on recent iSpot upgrades?

You should have to login to iSpot if there has been no activity for a certain, quite long, length of time. This is the case with almost all websites.
I do photo uploads rather than dragging across and it is working ok for me at the moment. In recent weeks there have been a couple of problems on the OU network which have affected many systems including iSpot but not aware of any issues at the moment.

Thanks Mike. As a very frequent user the repeated requests for log-ins came as a bit of a surprise. Dragging has worked for me in the past: it’s the method I always use. I’ll try another way - if I can work out how! - and will let you know how I get on.

:frowning: Selected files and set them to upload. Went for lunch. No progress.

Usual things to suggest including trying a different browser and clearing cache. Not had any other reports of problems uploading.

Cache cleared. Different browser (Chrome and Edge). Same problem.

Which operating system are you using. There is an issue that very old operating systems now (it is a recent change) can’t work with certain parts of the Open university system which includes iSpot I think, I am not sure if there is a workaround for this.

Do you know how large these images files are? I think we increased the limit recently, maybe even doubled it.
And are they JPG files? The iSpot code is limited in what file formats it can process.

Windows 10, version 21H1, OS Build 19043.1237.

Yes, JPG. I originally hit the problem with files of 6-7MB so tried with smaller ones ~0.9MB. The only difference is that the progress bar get around half-way along with the smaller ones before stalling; it barely moved with the larger files.
Files from the same cameras and in the same formats that I’ve been using with iSpot for years.

This is very strange as lots of other people have been uploading images to ispot today fine, infact I have uploaded about 30 large images today and all have gone through without any issues.

Could it be that the ISP is putting some kind of limitation on file uploads, some do make uploads much slower than downloads and might put other limits on.

Agreed! And it has only recently started: my recent posts at, for example, https://www.ispotnature.org/communities/uk-and-ireland/view/observation/831220/pink-barred-sallow-xanthia-togata and https://www.ispotnature.org/communities/uk-and-ireland/view/observation/831483/brown-roll-rim-paxillus-involutus are similar sized images from the same cameras.
I’ve not been notified of any changes by my ISP and I’ve managed to submit some of the same photos to other sites today.

Chris, perhaps the server logs or similar monitoring might give some info on this since they are supposed to be measuring everything about the site.

Screenshot 2021-09-22 165211
Screenshot 2021-09-22 165607
Don’t know if these screenshots help. I thought I’d caught the gremlin napping with the first one but it eventually stuck with the progress bar at ~95%. The second one is more typical of what I’ve been seeing.

Have just tried a couple of >10Mb JPGs myself. Either with drag-and-drop or with the file picker, the upload bar gets to 95% then pauses - just to make you think its thrown a wobbly - but then after a few seconds, does complete. I only presented it with one image at once, though - that could be a factor.

I’ve tried single and multiple images. On the one occasion when I got to ~95% it stuck for well over “a few seconds” - time to be convinced that it had really hung then take and send a screenshot.