Photos on observations

Looking through a few old observations and for some of them the picture is not displaying although it does show up in the thumbnail in browse observations. E.G. https://www.ispotnature.org/communities/uk-and-ireland/view/observation/651480/unknown-beetle-or-fly

It’s not all images as other ones do show a photo as expected.

I’m guessing this problem is just affecting some users since this entry https://www.ispotnature.org/communities/uk-and-ireland/view/observation/754711/ which fails to show a picture for me has just received an identification commenting on features in the pictures.

Yes. I’ve been browsing and housekeeping some of my old observations and keep finding images that don’t display unless one clicks on the “Full size” function.
Not linked to the current problem, but I’m also finding that OLD posts in the SA Community seem to have the wrong date - I think, one day earler than the actual date of observation. Not a serious problem. but may be if one searches for a specific date. I solve this, for myself, by setting a range of dates. (remember they changed the URL)
WARNING - Don’t try editing these old posts - some of the images may disappear.

This looks awful,as if there isn’t enough damage already. If you look at boasey’s uk&i gallery there are 4 posts, the 1st showing no picture; but when you open the posts none has a picture until you press full size (& if you press zoom it hangs)
I looked at my uk&I gallery & they all had pictures. However clicking on a random early post https://www.ispotnature.org/communities/uk-and-ireland/view/observation/83515/whelkcase046-
gives a blank invert sign & under the 1s photo shows but second shows no entry sign. Again when you click full size both photos appear. I tried 3 more posts on the same page with the same dud result. So it looks like none of the early posts work properly- who knows what other damage there may be?
My most recent https://www.ispotnature.org/communities/global/view/observation/756411/coscitenu450 Jan25 2018

Pretty sure even the Full Size function does not bring them back for me. Signing off for the night soon but will check again next time I’m on.

I’ve noticed before that one date searches often fail (as the case before all the recent changes as well) and that you need to do a range of at least two days to be confident of getting anything. Not sure why.

1 Like

Most of them appear for me if I go to Full Size, even where not visible as a thumbnail - so its work-able, but not a great intro to iSpot if you’ve not used it much before…

There are some issues here due to the method of getting back space so that new observations can be posted. Intermediate size images are being recreated on the fly from the originals and in some cases where the space had already run out then this was not possible. However now that there is space again you should see all different sizes of images but may have to wait a short while for the intermediate size image to arrive. Let us know if this is slowing down too much as we are investigating alternative strategies.

NB none of the above sizes has been restored
EDIT the 1st wks, the other 3 don’t
today I’ve found whenever I leave the forum I’m signed out, but clicking ‘sign in’ works. however there seems to be no way to start a new topic, which is why the comment’s put here. …but all now seems restored (except the 3 posts)

From your " may have to wait a short while for the intermediate size to arrive" I assume you mean seconds; so what about these cases , which haven’t worked for days, & 2 still don’t, https://www.ispotnature.org/communities/uk-and-ireland/view/observation/754711/ and https://www.ispotnature.org/communities/global/view/observation/756411/coscitenu450 (ie all 6 images)
Also I found my gecko not to work as in https://www.ispotnature.org/communities/global/species-dictionary/4462625/laudakia-stellio/observations (& in ‘my observations’)
Also https://www.ispotnature.org/communities/uk-and-ireland/view/observation/640852/unknown-ducks

I commented on the photo situation of the Shrew at https://www.ispotnature.org/communities/uk-and-ireland/view/observation/754711/
P.s I got an odd message posting this comment; it said It was already posted one day ago. Just saying.

Just for the record: there are several thousand observations on iSpot that have the creation date after the identification date. This is because in the Sept 2014 update the date of creation was accidentally muddled with the last edit date and the data corrupted as a consequence. It took a few months to fix, and during this time any edits reset the creation date. In theory it should be possible to fix based on the url number, but I suspect that with the June 2017 rewrite that is now no longer easily possible.

I wondered why so many of my observations showed a missing photograph: so it is those that I edited? And it is still a problem? I hope that when the Open University provides us with our southern African data for repatriation, that all the pictures will be included and that these are not lost. Do you have a way of detecting which observations are missing pictures?

Glad to see you here Tony, will answer you later.
But before I forget: This CREW obs needs an agreement - it’s ended up in FERNS https://www.ispotnature.org/communities/southern-africa/view/observation/745866/silene-undulata.
I’m having lots of fun with the new iSpot - it really works for me.
I didn’t realise how many observations I have at Cape Point and have had to put my lichens on hold.
ATTENTION YOUR TEAM - when I add a new observation (old) I often browse some of the others and am picking up rather a lot of mis-identifications which I’m sure really should not be transferred to iNat. I try to correct some - but when you or other experts have agreed - there is nothing I can do.
It’s a pity that we can’t work together - I’ll need to post a Silene for the CREW member to follow up. -
Now about your missing images - watch this space
DATES and IMAGES - I haven’t had a problem lately, so not quite sure - maybe it’s been fixed

1 Like

The Open University have not supplied any backups of our data since June 2017, so any changes made to IDs or comments after that date are - I am afraid - LOST!! They will not be transferred to iNaturalist. So any mistakes will need to be picked up there.
There is probably a way of getting them to take them across, but I dont have the programming skills.

But the ID tools on iNat are superb and the thumbnails are double size, so that mistakes are very easy to pick up in the species pages (esp the grid view, but also from localities using the maps), and the pool of experts there is growing daily. Some “experts” (they count as just another vote on iNat) are quite excited by the tools, and lo and behold I might even get John Manning interested: he never spared iSpot a second glance after having tried it out, but iNat allows you to manage your curation.

The dates and images have been fixed, but the data corruption that occurred while the bugs were in operation have never been fixed, just totally ignored.

Curious that an “expert” does not know the difference between the two spellings - the fern and the scroff …
(Heavens: how do you put up with the page jumping all over the place when one agrees: how did I ever enjoy this site?)