The OpenScience Laboratory The Open University

iSpot Forum

Problem uploading iPhone "Live" Photos

Both last week and today I have had some issues uploading photos from my iPhone (via my Mac). Most of the photos for my observations uploaded properly, but some failed to upload. The error message said 18N Backend.Message.Image.Invalid_IMG_FILE

Originally I thought this was at random, but looking back at the photos on the phone I realised that the ‘live’ photos I had edited failed to upload, but the unedited ones uploaded.

Previously I had no problems uploaded both edited and unedited photos.

However I have now realised that I have also successfully uploaded some edited ‘live’ photos today.
All rather strange!

I think Admin might be interested in some specifics. For example what type of pic suffix .jpg/img sort of thing.
The forum is easier-going, load in one of your difficult pictures here (drag and drop or copy paste) and see how it goes.
We have not heard of uploading issues for a long time

Of course I’m happy to provide further information about the situation.

When Apple Live is used the iPhone takes multiple photos over a short period of time. The phone sets one of these photos as the default one. (I’m describing this as unedited.) Alternatively one of the other photos can be selected to become the default photo - perhaps because it is more in focus. (I’m describing these as edited.)

Recently only the unedited photos will upload to iSpot, whereas the edited ones fail.

The files are in Apple HEIC.

I haven’t heard of this bu according to Wikipedia “ HEIC is the file format name Apple has chosen for the new HEIF (High Efficiency Image Format) Standard. Using advanced and modern compression methods, it allows photos to be created in smaller file sizes while retaining a higher image quality compared to JPEG/JPG”

I don’t think the problem is caused by something like a poor USB connection.To test this I’ve downloaded both edited and unedited photos from my phone to 2 different computers using different connection leads, but when I then tried to use the computers to upload the photos to iSpot, only the edited ones fail to load.

As suggested I tried to upload one of the difficult photos to the forum but I had a message saying that the photo was corrupted and they system could not determine the image size.

From this it seems likely that the fault is arising from either the Apple iPhone 8 software or iSpot, rather than the intervening computers.

Interestingly I have gone back through the photos and the problems have only arisen with ones taken from 30th October onwards - although I might have edited them a few days later. This was around the date when Apple updated iOS14. Clearly it is a possibility that changes in the Apple iOS operating system could have some sort of connection with the problem.

You can edit entries within 28 days by clicking the Pencil. You can delete comments by clicking the (Binnit)

Thanks for those valuable tips

I have a video (already reduced to 14.7 kb) but cannot load it.
Does iSpot not support mp4?

I think you’ve got to host it elsewhere and post a link.

Oh, thank you. Disappointing, but c’est la vie.

I stick videos on youtube and sounds on soundcloud and in each case put the link in the ispot observation and in case of video also do screen grab to put in the observation. There are other video and sound hosting websites that also work. We don’t have enough space etc to host the other media formats yet.

iSpot supports only JPG, PNG and GIF image files, any of which needs to be under 30Mb.

Incidentally you shouldn’t ever see error messages like “I18N.BACKEND.MESSAGE.IMAGE.INVALID_IMG_FILE” - that should have come out as human-ready text!

a new interesting issue for me today @Chris_Valentine .
Uploading photos in the normal way, a ghost appears - an empty photo-holder or two.


PC/Windows10/Chrome
Easily deleted and did not affect the upload

Looks like it simply doesn’t recognise those two files as images.

No, this occurs as I load in one normally, it produces a Ghost just above it -,seen above. It happened a few times today. There are not inserted by me, they are added the moment I drag in the real one. It is not a significant issue in that I can delete the ghosts immediately or after all my pics are in.
I cannot replicate it at will (I have just tried), it just occurs sometimes.

@Chris_Valentine I had a few broken links in my Tracker this morning - anyone else?
this is one - works without the suffix,

Yes. Clicking on a ‘Title’ from my ‘Changes Tracker’ is bringing up the message:

403 - Forbidden You do not have permission to view this page.

A widespread and irrational bug. Chris_V is on the case but is supposed to be on leave until Monday

This is a particularly odd issue because all you’re trying to do is view an observation, an action that does not require a user to be logged in. If you find this is reproduceable for any given link, can you please post it here so others can test it, please?