An evolving issue

I’m interested in a rather frustrating issue - or, rather, the way that ‘The Gremlins’ seem to be evolving to maintain the frustration.
A while back, iSpot took to relocating all my locations to my home. I discovered a work-around, which was to start by clicking in the Grid Ref box (sort of ‘waking the map up’), then entering the location.
But that only worked for a while. Then, the relocating started again, but no longer placing everything in Sawtry. This time, the positions were usually moved to a point a few hundred metres to the south-west of where I’d tried to place them. Another user noted that they had found a work-around - clicking the ‘hide precise location’ box, then un-checking it. That worked for a while, too.
But now that doesn’t work any more, either. I gave up today, and let iSpot put the locations where it liked. It’s quite tempting to believe in evolving Gremlins…

1 Like

I’ve been having location problems too, my recent Bempton cliffs observations have all been moved a little way away. I tend to manually move the pin to the location I want but then when I upload the post it has moved again.

You might well find this a faff but I use this site:

which always opens in Beds as that’s where it was set up for, I presume.
I like it because there are different ways to get the spot and then you use the left-hand map with the moveable pointer for more precision.
You can search by Postcode, town, street, church name or similar in the Go to Grid Ref box.
I tick 10m square (Red) as well as WGS84 for the Lat Long coordinates.
I insert the Lat & Long into the relevant location boxes and if I want to be more precise, I add the 10m sq Grid ref into the Location notes box (to appear under the map).
Try it!

I find iSpot automatically inserts the location, I guess it can ‘read’ photos. I didn’t choose this as an option but I’m happy with the arrangement.

That is really helpful thank you - without sounding a bit daft, I’ve never known how to find the grid reference before. I therefore normally just type a nearby place name into the iSpot location field then choose the option it gives me, then move the pin manually closer. This used to work in terms of accuracy but now it doesn’t. In future I’ll use your link - thank you!

1 Like

ISpot no longer picks up the EXIF data from my camera JPGs (it doesn’t have location data, but the date used to be imported automatically). Oddly though, it will pick up both date and location from Android phone pictures.

It used to pick up the date from my hand held camera but has stopped now.
My camera does not have GPS.

I have my own version of this (Northern Teacher’s comment). When iSpot abandoned saved locations, I set up a spreadsheet of grid references for my local sites. I copy-and-paste these into the text box. It does not prevent iSpot from picking it’s own location, even if I refine the position. I haven’t tried doing it with the lat. and long. values, though.
I shouldn’t grumble. I get to use iSpot for free. If the Gremlins want to have a bit of fun winding an old slightly OCD bugger up, so be it.


It is down to the library that reads the image exif, there does not seem to be one, at least none that Chris could find, that reads it properly from all cameras and phones. At various times we have tried different ones in the hope that they will be better which is why it may work for a camera or phone then stop. Not made any changes for quite a few months now though.
On sites that somehow seem to read all phones/cameras then I suspect they use more than one library or some other trick.

I rarely have difficulties with Location, even with twn fig refs or clicking the Satellite map… I edit others’ Observation locations too.
For my own, I sometime type in the village name (Orphir) I get two choices one in France but otherwise it takes me to a nearby location and I just click on my own. It rarely fails.
I recent times I have had to resort to naming a nearby place - chasing down user’s mislocations
You would honestly find it amazing how many obscure locations the World over (except Smoogro) are stored in Google - try

In fact, that’s what I just did.
The issue remains the same. iSpot moves the location, and it has a clear preference for moving it to the south-west.
What I have found is that if I set a location, then click in each of the Grid Ref, Lat. and Long. fields, one or t’other (not reproducibly) will cause the move. If I drag the location back to where I want it, and repeat, this may happen again. But, eventually, the Gremlins seem to get fed up with the game.

I have also had some issues when trying to correct a couple of the recent schools observations which were thousands of miles from where they should be. In that instance it was a matter of removing the ‘hide exact location’ then slowly typing in an approximate correct location (I am hoping they will fully fix the locations themselves) then putting back the ‘hide exact location’. The slowly typing part seems to be important for some reason. Possibly Google have changed their system yet again as dragging the point to the correct place does not seem to work for these corrections.

I tried this morning to rouse the Devil you mention
I tried allowing my camera’s EXIF (GPS Location) to talk to iSpot - it worked well.
I set to OFF afterwards (don’t forget)
It is worth noting that modern cameras ignore the GPS command and still store the location
Check the GPS setting in your camera - remembering that GPS is sometime WILD.
I also found a way to STOP Google from remembering my location, bearing in mind iSpot relies on Google for many things.
I tried typing in 10 figure grid refs. iSpot appear to ignore 4 of these but in reality actually plots the location to ONE metre IF you ask it to.
I find it too laborious to play with Lat Long but I copied from one Ob to another - it worked seamlessly.
I nearly always use the Satellite location photo, fences, road junctions, small plots of vegetation are seen from space. I quickly noticed again that the Map is slightly different to the Satellite view but not by much
I tried a number of ways to make it difficult for Spot and actually failed.
This makes me suspect that you have a PC issue, that Google locates YOU wrongly
Or the camera is sending confusing locations (switch OFF GPS)
And that you should completely clear your Browser (NOT passwords) more often, paying attention, somehow, to location memory (google search “Switch off location services PC”) .
Might you try loading in an Observation (or change a location) via your Phone or Tablet (what a chore) that will probably prove your PC is the Devil and that your Provider’s Server is in the South West.
If your photos are from a phone, then you need to pay special attention to the EXIF information, few of us have Location Services OFF.

The camera I mostly use (FZ2000) doesn’t have GPS. In fact, iSpot doesn’t seem to pick up anything from photos (date, f’rinstance). A recent post (Attacked! | Observation | UK and Ireland | iSpot Nature) featured two Android phone photos: they allowed iSpot to pick up date and location, and there was no repositioning done - the pointer sat in exactly the correct place.
It makes sense that it is Google that’s at fault here. What is odd is that the relocating seems fairly consistently to the south-west of the intended spot, though the distance is less definite.
I always clear browser data after use, and I don’t use Google either as a search engine or browser. But the damned thing gets everywhere. In fact, I should probably start my acceptance speech (induction into the Grumpy Old Beggars Club) by thanking Mr Google…

Oh I’m so pleased you have raised this - I thought it was me doing something wrong (not unknown!).

A Grid Reference is never offered - I find the location on the map provided and click on the map to get it - sometimes it accepts it and changes it to my home location later, sometimes immediately but like you, I persist two or three times and eventually it gives up. Worryingly I sometimes notice on checking an old observation that the Grid Reference has been changed, but whether that is down to me not noticing at the time or mischievous gremlins waiting until I leave the site to pounce, I’ve no idea!! It has to be said, it is an irritation rather than a problem - just relieved to hear others are running into it as well.

@surreybirder just gave me a great workaround that seems to work. You put the flag where you want it, then click hide precise location, then click hide precise location again and it seems to stick! Although noticed that @Amadan said this stopped working for him after a while…

Indeed it did work for a while. My latest trick (described somewhere here) is working at present.
I should learn to live with it, but it is what’s left of the seeking of scientific precision that I once pursued that plagues me.

That is YOUR settings in your device coming into play “allow my location…” or somesuch needs clearing or switching off.
I remember long ago that My ISP server (in London) became a default location - no longer.
I seem to have none of these issues and yet wish (only sometimes) that when I add an Ob. I didn’t have to zoom into Scotland and much closer, EVERY time I add an Observation. And yet I DO allow Google to know my location and my phone always has Location ON.
I cannot recall ever having to correct a location (of mine) more than a few metres.
So, this could be to do with us allowing Google to take over. There is plenty of advice on the Web (via Google!) about hiding locations and Browser Privacy settings.
I’d hate anyone to think I was unsympathetic. I do get a lot of personalised and regionalised Adverts "Thousand of nearly new cars are being sold off in Kirkwall - click here…"
I also notice that most named places have a default location, so if you type Bath Street as a Location Title (you do) then it might try to find the one in Nottingham when you close the Observation. That’s a bad example, even unlikely, but Hampstead Heath has a default location that could be 500m from the iSpot correct location. So location titles may have an effect.

to THE Southwest of England or just SW of the precise spot?
I have suggested above that the Google Map location has a default position. So if you type Glapthorn it will go where Google has the default, which may be 200m SW of your iSpot. I am suggesting that if WE use the Village or Nature Reserve name as the title, then maybe, only maybe, the Night Gremlins will have fun. I hope Smoogro drives it crazy!
Have you noticed that PlantNet has ‘fun’ in the very early hours?