The OpenScience Laboratory The Open University

iSpot Forum

Bugs Alphabetical P

***** P ***** All bugs beginning with P

Previously-entered locations missing
I think I’m being obtuse, but I can’t work out how to “recall” a previously-entered location. I’ve posted several observations from the same site, but have had to re-enter the location each time.

Preview Missing before posting
No preview before posting a new observation.

It is a useful facility which has been lost in the re-build.

Previously-entered locations missing

Listed in the Bug Catalogue:

Bug #118 Add an Observation: location tab locality title box Locality (The location page doesn’t remember my previously entered …
Bug #119 Add an Observation: location tab locality title box Locality: (“location title” doesn’t seem to search for previous titles : this was advertised as a feature…

Preview Missing before posting

Listed in the Bug Catalogue under:

Bug #128 Add an Observation: PREVIEW (and Bug 44461/20)
Bug #139 ADD PROJECT
Bug #452 COMMENT PREVIEW
Bug #454 Pictures not loading or not showing …
Bug #40 YNAME -> YOUR ISPOT -> OBSERVATIONS - preview option

Irritating - I’m getting yellow boxes from the system “How about a picture for your account?” - I did upload a ruddy picture; how is it even possible for it not to appear on my stuff when other users’ pictures do?

Frustrating, innit?
I tried changing mine. It allows you to do so, but the change doesn’t “take”. According to the wise, elsewhere in the Forum (which is rapidly becoming un-navigable due to the sheer weight of posts), iSpot grabs photos from another site specifically designed to store such data. Seek, and ye may find!
Quite what the advantage of this - apart from demonstrating programming skill (notably absent elsewhere on the site) - is, I have no idea.

I tried again and seem to have a picture (and without clearing my browser cache!) so perhaps I missed the Save button you have to scroll down to. Lets see if it stays there.
I’m retired from a job as “owner” of a database and application. Some mistakes are made by programmers (though I’d always rather pay one than do programming myself) but serious ones are usually made by those instructing them.

This is a good point. Who is the current executive?

PICTURE THIEF
is alive and well. Two occurrences in 24 hours. Editing post, pictures absent at first try.
No pattern in the lead-up, just random.


Picture here shows the two attempts.
the arrowed header reads, in both cases https://www.ispotnature.org/communities/uk-and-ireland/edit/observation/746951

If images are absent DO NOT SAVE, go back and try again. When editing text ALWAYS check that Images are present, otherwise abandon attempt.
Is ANYONE interested in this @miked ? the site is suffocating from lack of communications…

me too. Very annoying.

I believe they might NOT be because, if we save after an edit, it is as though we have removed the Pix. I am not prepared to shout into the wind (no one can hear) so I just put it right, if I can…
It is ‘registered’ as a Serious Code aberration (SCab), so until it’s fixed, I’m going to soldier on under protest, gradually weaning off and reducing my commitment.

Please try and test this.

Post a test observation and get the picture addresses (copy the picture url). e.g.

for


the pics are:

(big pics) https://api.ispotnature.org/storage/app/sites/default/files/frontend/21890/201710/1454904_cuts/large_P9261151.JPG


& (Thumbs) https://api.ispotnature.org/storage/app/sites/default/files/frontend/21890/201710/1454919_cuts/small_P9301193.JPG

Then try editing it several times until the Edit Observation Wizard uploads without the pictures. edit and save.

I am willing to bet that afterwards the pictures will still be there, even though the observation shows no pictures.

Please test my hypothesis (logic: if the wizard loads without the pictures, it wont know which pictures to remove, so they will just stay there)

In which case the bug is simply: when and why does the Edit Observation Wizard load without the pictures? Is it during the GET, or during the page compilation? If it does not load the correct pictures, why is it not being detected and fixed without any need for the user to be aware of the issue?

That post is perhaps too precious to risk losing its integrity (I edited it 3 times this morning!). So I will do a series of test posts later today and report. I notice that when the thief is present the green TICK in Images box is absent. If I was a code writer I would put a LOCK switch on illustrations - locks the Presence, Order and Location, until unlocked by User. A lock on HTML would be nice! I have to replace it EVERY time I edit!

If this is true, then it should be easy to trap this bug, no matter what its cause …
No excuse for it still being an issue.

I also want (as we used to have) iSpot to remember if my maps were satellite or map
I also want (as we used to have) iSpot to remember what filters I last used in community, but most especially under Track Changes!!

I have opened and closed this 24 times. You know, of course, as I have set a trap, she won’t come…

Ah: but she is aware of a trap.
You should rather have had Undock - then she would not have been able to resist …

I have given up here… I could not paste the Img addresses in the description panel and, in any case (I am wondering) WHY should I? I am genuinely interested but is anyone else? probably not.
So I have enhanced the post with 15 pictures in the hope I do not miss the Thief, if she comes.