The OpenScience Laboratory The Open University

iSpot Forum

Changes Tracker faulty

Has anyone else noticed this sequence …

  • Select Changes Tracker
  • After a long time you are told there are no changes available
  • Reload page
  • Very quickly comes up with 500 Internal error: something has gone terribly wrong
  • Reload page
  • Changes are displayed but the most recent ones (ie those since you last saw them) are not highlighted.
    .
    I’ve seen this on several occasions recently.

Not with the changes tracker particularly (although it’s very slow), but that error has appeared at various times (it makes a change from “unresponsive script”, which plagues my attempts to access the site via my Android phone).
Following advice, I tried clearing the cache: this seems to work. But, I have found that on occasion, Firefox has reported that there was very little in said cache. Hey ho, if it works…

I’ve only seen this particular sequence with the Changes Tracker, though, like you, I’ve seen the error message in other circumstances.

Does this happen when the whole site is running slowly? I’ve had similar things once or twice and suspect it is when there is a site backup running. This runs at the wrong time of day on some days when there are lots of people using the site rather than when the site is quiet. There is also a particularly high load on the university network during lockdown as everyone is working from home but using university systems and there can be peak loads with aspects to do with exams and similar.

1 Like

Really not aware of any particular days / times but I’ll look out for it. It certainly happened just before I posted the original report this morning.
.
As for the site running slowly, I think it is always one of the slower sites I visit and I’m rarely aware of it being particularly slow. I’m in the habit of setting it to display the changes tracker and then getting on with something else on my desk before looking for the results.

Just happened again (2020-05-25; 2038) on a different computer.

Twice this evening just after 2100.

And again today, no changes shown up on the tracker.

Getting fed up with it this afternoon. At least 3 times. Grrrr!

I’m currently having the plant carousel hang up frequently. The changes tracker failed once recently, and so did adding an identification.

BIG improvement after today’s upgrade. Many thanks.

1 Like

No change here, but there are lots of comments on social media about how slow the internet is, locally.

I agree, not much change. Is there some feedback from the Coding Team - please?
image
.
Seen this one? Bet not!
I often have several iSpot Tabs open and Chrome makes this an excuse to use more and more resource.
So yesterday I added a SAFE Browser extension called The Great Suspender. It puts to sleep those Tabs that have been inactive for a while. They are easily ‘brought back’ with a click.

I tried the Changes Tracker first thing this morning and it loaded in about a second. Tried the Activity Tracker just now and it took probably 3 seconds to load. I suspect that the memory increase helps more at the quieter times, but won’t have the sizeable impact we all want it too because at the end of the day, the volume of data is very significant and the queries are probably not as efficient as they should be.

I dream about this loading in 3 seconds. I timed it just now at 45 seconds which felt typical of the improved performance.

Thanks for the response. I am not certain YOUR ‘first thing’ is the same as mine. But I measure ‘improvements’ by refreshing my Project Maps or Galleries. I suppose much will depend on DownLoad speeds as well. a lot of us are probably well below 10Mbps (mine is 6.5mbps) - yours Chris_?

I have a fibre connection - about 30MBps. If the site is plotting things on a map, that’s using Google’s API and that will also be a bottleneck.

Just checked mine here: 6.81Mbps download, 0.54Mbps upload.

With the site only sending small images (unless you’re looking at an individual observation) data quantity shouldn’t be significant factor in the speed of response.

Quite. So why is your response time so much better than ours?