The OpenScience Laboratory The Open University

iSpot Forum

Missing Image where has it gone?

This entry (https://www.ispotnature.org/communities/uk-and-ireland/view/observation/756533/) had an image when I provided the ID but no image is now displaying.

No problem - I’ve found out that if you click on “Full Size” the image appears.
See if that works for you - maybe the internet is just slow in uploading (Actually I have no idea why!!)

19 hours later, and it’s still not available, except as Full Size. That’s more than a slow upload… It may require attention at Home Base.

It is a good idea to flag Home Base occasionally - not too frequently otherwise they may ignore us @Janice_A & @miked

Here’s some so slow they haven’t uploaded since before Feb 15! when I posted:-
what about these cases , which haven’t worked for days, & 2 still don’t, https://www.ispotnature.org/communities/uk-and-ireland/view/observation/754711/5 and https://www.ispotnature.org/communities/global/view/observation/756411/coscitenu4501 (ie all 6 images)
Also I found my gecko not to work as in https://www.ispotnature.org/communities/global/species-dictionary/4462625/laudakia-stellio/observations (& in ‘my observations’)
Also https://www.ispotnature.org/communities/uk-and-ireland/view/observation/640852/unknown-ducks

Thanks for letting us know about these. If you spot any more then list them here too. Will pass info to programmers.

Missing MAP
I also have a problem with a Robin that I photographed at East India Dock - just a hair’s breadth from Greenwich - but the picture ended up on the Equator so not appearing in the Project
This is the re-post with a link to the original


and the comment appears below https://www.ispotnature.org/communities/uk-and-ireland/view/observation/762510/robin-east-india-dock-basin-2018

https://www.ispotnature.org/communities/uk-and-ireland/view/observation/752164/large-house-spider in https://www.ispotnature.org/communities/uk-and-ireland/species-dictionary/NHMSYS0020706536/tegenaria/observations

Found another - is this what we should be doing? Don’t want to nag.
The image is there - https://www.ispotnature.org/communities/southern-africa/view/observation/752051/zygophyllum-fulvum-roadside

Those pics (ChrisA’s spider and Marlanza’s plant) ARE visible (to me)

So what happens when you try the 2nd link I gave (after the “in”), https://www.ispotnature.org/communities/uk-and-ireland/species-dictionary/NHMSYS0020706536/tegenaria/observations & scroll down the list?

I think you know - I saw that it did not display in the Filter but who cares when it is seen properly in Other Obs and as a full Observation?
There are plenty of these ‘delaying displays’ in iSpot, some come after waiting long enough (but too long). Many of those that are really stubborn have comments (by me) for the User to reload. But if the user can’t be bothered why should we fret?
Some, of course, are truly frustrating - I remember many from 2017 ‘Picture-thief’ episode - most are still missing because the user has ‘gone’ or has never accessed their C.tracker.

The point is we were asked to point out missing images, & NONE of the cases i’ve mentioned will display however long you wait, & the same is true I’m sure for David Howdon’s case. So it’s something that needs investigating & correcting

did you type in the os grid coordinates or lat long or let the system pick up coords from image or click on map? I can see it has 0,0 for lat long coords so this may be why no map appeared.

Thanks for getting back Mike - I think I would have copied the OS number and then adjusted the spot from the map - I generally do this for East India Dock Basin, as well as for my other project on the Isle of Dogs - this seems to be the first time it’s happened

All three of those excellent pictures are available to me Chris after a little wait.
Some of these difficulties are related to the size of the Image. Picture 1 is HUGE and accepts extra-enlargement.
Difficulties also arise with download (broadband) and transfer speeds from Routers, also the way our processors handle display (I know to my cost). But I believe the site itself is slow, compared to many I use. I wonder what the Hardware Upgrade last week was for?

Can we sort out once and for all that these are not a matter of slowness; the images never appear!
Any post shows the cuts/large &(if there’s more than 1 image) several cuts/small (as well as cuts/small for other obs strap.
Also a list of observations shows the cuts/medium
EG https://www.ispotnature.org/communities/global/view/observation/756501/hermodice-carunculata215 shows https://api.ispotnature.org/storage/app/sites/default/files/frontend/5824/201801/1479078_cuts/large_Hermodice%20carunculata215.JPG
and
https://api.ispotnature.org/storage/app/sites/default/files/frontend/5824/201801/1479078_cuts/small_Hermodice%20carunculata215.JPG etc
And you can copy the addresses by moving pointer into the window, Right-clkg, clkg viewimageinfo & copying the Location: address
So going right to the top, in David Horton’s case https://www.ispotnature.org/communities/uk-and-ireland/view/observation/756533/forest-bug
it’s the cuts/large that’s missing (but the image is there https://api.ispotnature.org/storage/app/sites/default/files/frontend/66602/201801/UI01.jpg ),& from another of same species we can get the cuts/small https://api.ispotnature.org/storage/app/sites/default/files/frontend/66602/201801/1479174_cuts/small_UI01.jpg Also replacing small with medium also works https://api.ispotnature.org/storage/app/sites/default/files/frontend/66602/201801/1479174_cuts/medium_UI01.jpg
but cuts/large says “the image cannot be displayed because it contains errors” NB how all these cuts have the same number (ie 1479174) which looks like a rule

If you actually find any of these images Dejay please copy the addresses & post them in this forum

It appears that part or all of this issue is to do with attempts that were made to save space i.e. deleting certain sizes of image that were not required until someone actually looked at the observation (and at that point these intermediate images could be recreated on the fly). However this did not work as the search engines caused many of the intermediate sized images to be re-created anyway and they are constantly going over the site. Between these two processes the system seem to have permantly lost a small handful of the intermediate size images. It is not clear if re-uploading the original image will fix the problem in these cases but it is something the users could try and let me know the outcome.