The OpenScience Laboratory The Open University

iSpot Forum

Broken since the upgrade?

Has the recent upgrade (I’m assuming there has been once since the font and a few cosmetic things have changed) broken something? Pages seem to take multiple goes to upload (often just uploading with the headers but no content the first time), intermittent ‘something gone seriously wrong’ messages, changes tracker showing no changes.

I’ve also had the ‘seriously wrong’ message & many ‘misfires’ eg one post showed only the comments ,& another with long comment trail showed ‘no comments’ (but later loaded ok)

Yes indeed we are now running faster and paying for it with errors and a need to refresh the screen quite often.
Once the errors are sorted out it will be a great improvement.

Fingers crossed it won’t take long to correct. This is the second day. :frowning: Two 504 errors following attempts at one agreement this morning before it was accepted. Refreshing the page sometimes works following an error message but not always.

This morning:


And

And

That was the second attempt: the first produced the “no-entry” sign, the 3rd try:

Updated: this is what I mean by the "no-entry_ sign:

But when it works, the site is pleasantly fast!

Many, many errors yesterday (I made another comment somewhere) the 504 ones, failure to add agreement, no comments appearing when there should be, many steps in the process taking two or three attempts to go through error free…

Out today, so thought I’d have a look this morning: just the same I am afraid. My tracker said two people had commented on an observation to which I’d added an Id, but no comments showing. Quick look at community- no observations!!! Also Gateway timeouts and other errors. Other sites working, email working etc etc. Adding an observation took ages, multiple issues to get it done. Similar on desktop and on iPad. Hope this gets sorted asap.

Thank you all for continuing to feedback…and sorry that you are continuing to experience problems on the site today. Do please bear with us whilst we look into this.

Not running faster, it’s taking ages to load only part of the page

Sorry for the issues. We’ve just found that one of the database servers has run out of storage space so we’re currently attempting to expand it. The site will likely be offline for at least 1/2 hour.

The iSpotnature.org website is down at the moment. We are aware of the issues and are working on them and apologise for any inconvenience caused. Please do bear with us.

Dear all
The following update has been posted on the front page:

Development updates - iSpot issues and errors: September 29 - 30

You may have noticed that during this week, particularly September 29 - 30, the iSpot website had some downtime, issues and errors and we also started implementation of the iSpot refreshed design. As we attempted to apply fixes other technical issues emerged and the website had to be offline periodically while we worked on this.

As part of this we had to revert an earlier backed up version of the site therefore some observations, comments etc posted between September 29 – 30 may not appear we are looking into this further. If you notice any irregularities with observations, other posts, functionality etc. please do let us know via ongoing forum discussions underway here: Reverted to a Backup? or Broken since the upgrade? . You can also use contact us or email at: [email protected].

Thanks again for bearing with us; we do apologise for any inconvenience this has caused and any ongoing issues as we continue to work on things. We will update you further as we make progress.

It was running OK from 10:30ish to 07:30 this morning then the same thing happened. As soon as I restarted the relevant webserver it sprang to live.

I managed to log on and post an observation this morning before everything ground to a halt with only the loading circles spinning round and round. I tried logging out and ‘log out failed’.I’m surprised the Forum appears to be functioning. Hopefully, things will improve without anyone becoming too stressed:-) Take care,

The forum is hosted on a completely separate server so isn’t affect by the main site. I took the same action as earlier and the site sprang straight back into life again.

At the moment I can only apologise again - we’re as frustrated over this as you guys.

1 Like

Having run computer networks in the past, I can but sympathise with you. It’s never easy when the technology fights back and particularly when it seems to strike at random.

If it was happening on some kind of regular basis - say every 24 hours or every hour - we would know to look at the scheduled scripts and backups - but its more random than that.

@miked
Is this broken or just an error by the observer?
Looks as if they may not have drawn a map of the walkway

Interesting. Never seen an observation record without any location data before.

It appears very odd. It’s presented as a project, not an observation, I think. But the “observations list” is coming up blank,
image

while the “observations gallery” seems to be a repeat of the main UK site observations list.

Has been submitted in the Global community. And as you say, that project observations list doesn’t return. I’d have to dig into the database to solve this one!