The OpenScience Laboratory The Open University

iSpot Forum

Reverted to a Backup?

The site seems to have reverted to a backup version. What will happen to observations posted since 29 September 2021 - 12:43AM?

Yes, I see ( or rather don’t see) observations put on yesterday 29th are not there at all. Expect this applies to comments and agreements as well?

It seems to be the previous version of the site software and a backup version of the observations data from the early hours of 29 Sept. I’m hoping that some of the (very large amount of) work going on in the bowels of OU Towers today will be an attempt to recover the changes made to observations data since that backup. Time will tell and I’m sure @Chris_Valentine will be along to update us when he has time.

Yes, time will tell.

The server was restored and running happily at about 18:30 this evening but now its ground to a halt, even though the system that monitors all parts of the server cluster says its happy. Watching the webserver log file I can see requests getting through but it certainly won’t serve anything to me. There’s also plenty of space on the database servers, so its not down to those.

Thanks for the update @Chris_Valentine . Fingers crossed that you can get to the bottom of this before too long. Thanks again for all your efforts.

Running again now but currently we don’t know why it spat its dummy. Neither of the database servers appeared stressed at all. We restarted one of the webservers and it sprang back into life.

Thanks for update, appreciated.

Dear all
The following update has been posted on the front page:

Development updates - iSpot issues and errors: September 29 - 30

You may have noticed that during this week, particularly September 29 - 30, the iSpot website had some downtime, issues and errors and we also started implementation of the iSpot refreshed design. As we attempted to apply fixes other technical issues emerged and the website had to be offline periodically while we worked on this.

As part of this we had to revert an earlier backed up version of the site therefore some observations, comments etc posted between September 29 – 30 may not appear we are looking into this further. If you notice any irregularities with observations, other posts, functionality etc. please do let us know via ongoing forum discussions underway here: Reverted to a Backup? or Broken since the upgrade? . You can also use contact us or email at: [email protected].

Thanks again for bearing with us; we do apologise for any inconvenience this has caused and any ongoing issues as we continue to work on things. We will update you further as we make progress.

Very sorry but as part of our efforts to fix it yesterday we reverted to a backup from the morning of 29th, meaning about a day of activity has been lost.

OK, we surely understand that you are all trying y’r best.
Thanks for efforts…have a get well soon card!

1 Like

I am having difficulty from time to time this evening and I’m reluctant to do much on the site! ( Pandemic has hit my resilience I think, hence reluctance.) I tried to look at an ‘other observation’ while viewing a recent obs but just got blanks where image and ID should be. On third try it was fine. Images slow to load so no entry signs when reviewing community observations till a couple of minutes have passed. Other sites and email all fine.

Are you coming out in sympathy with the server or vice versa?

Is this a quote from you or from the server “I am having difficulty from time to time this evening and I’m reluctant to do much on the site! ( Pandemic has hit my resilience I think, hence reluctance.)”?

1 Like

This evening the Changes Tracker is timing out. Displaying carousels and individual posts seems fine.

We had another server crash around 20:18 - back running again now - which is more than I can say for Facebook and WhatsApp.

Changes Tracker still not working. If I leave it long enough I’m eventually told “No changes available” (or similar). Also getting the “Something’s gone terribly wrong message” (and, as you say, similar from FaceBook.)

Good point!!! :grinning: -) plus other characters

For me, Changes Tracker loads instantly.

I was going to ask how everyone was doing today? :slight_smile:
Moving around within iSpot, viewing the Gallery, commenting on observations, confirming ID’s, using my iSpot Profile, switching between the Activity and Changes Tracker and Project area are all working fine for me… I’m going to attempt loading new observations next…

I’ve been brave and started to add observations, including the weird feeling of adding what you thought you’d already added! Some slowness: slow to bring up images and changes tracker has been slow. Something strange: when using the Species Dictionary, Observations, I couldn’t persuade a second page of observations to open up - total number given was more than one page worth in each case.